Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Интеграция и конвертирование

Интеграция Drupal 6 и phpBB3

Взаимодействие phpBB 3.0.x с другими системами.
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Конвертеры

Сообщение 23 июл 2009, 16:18

b-man писал(а):Ошибки вылазят только при изменении типа отображения форума

при каких настройках все ок?
сделай скрин с экрана.
Я завтра погляжу, подумаю...
Не пробуй! Делай или не делай! Нет слова "Попытка"!
mr_james
Активный участник
 
Сообщений: 56
Зарегистрирован:
03 фев 2009, 14:48
Откуда:
Большой Камень, Приморский край
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июл 2009, 17:38

Захожу в phpBBforum settings (в данный момент стоит режим «In frame inside Drupal page»).
Пишет что все ок:

Изображение

Выбираю показывать в окне, сохраняю. Друпал пишет все ок – сохранено.
Перехожу на форум – белый экран

Опять захожу в настройки, выбираю «In frame inside Drupal page», сохраняю:

Изображение

После перегрузки страницы ошибка пропадает.
При этом форум работает нормально:

Изображение

Выбираю «In the Drupal page. (Except for ACP)»

Сохраняется без ошибок.
Форум отображается коряво:

Изображение

Также выяснил что ошибка появляется ТОЛЬКО после того как я изменяю режим «In the window» на любой другой.
b-man

 

Сообщение 06 авг 2009, 14:47

установил форум, но при заходе в модуль phpbbforum выдает
"Fatal error: require_once() [function.require]: Failed opening required 'блабла/modules/phpbbforum/includes/phpbbvbridge/PhpbbVBridge.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /блаблабла/modules/phpbbforum/includes/phpbb_api.php on line 174"

В чем может быть проблема, сразу скажу новичек в этом деле, не скрещивал раньше, вот захотелось иметь нормальный форум...

Помогите разобраться...


Заранее, спасибо!
Vovu4a

 

Сообщение 17 авг 2009, 13:57

удали install и нужен PHP5
Alamner

 

Сообщение 17 авг 2009, 15:51

Всем привет!
Сразу извиняюсь за столь долгое отсутствие. Сами понимаете, работа, бытовуха и т.д.
Alamner, рад, что у тебя (надеюсь, не против обращения на "ТЫ") все получилось.
Простой совет на будущее, для всех.
Читайте про системные требования.
Это не издевка и не сарказм, это действительно помогает.

Еще. Всегда записывайте в каких файлах и какие изменения делали. Но это, если сами модификациями занимаетесь. :)
Если у кто захочет что-либо узнать/спросить/посоветоваться оставлю координаты.
ICQ: 4три09два96семерочка8

К сожалению, не могу обещать, что отвечу, но постараюсь.
Да, и не забывайте про часовые пояса :)
На момент написания сообщения у меня на часах 22:50.
а в сети я с 19:00 по МОЕМУ времени :)
Вопросы?
Не пробуй! Делай или не делай! Нет слова "Попытка"!
mr_james
Активный участник
 
Сообщений: 56
Зарегистрирован:
03 фев 2009, 14:48
Откуда:
Большой Камень, Приморский край
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 16 сен 2009, 06:13

Подскажите, если друпал и phpbb3 стоят на разных доменах
drupal.ru
forum.ru
интеграция возможна? Что для этого необходимо?
primkray

 

Сообщение 13 ноя 2009, 05:25

От блин.
Пытаюсь все делать по инструкции этого модуля. Дошла до третьей части, то есть патча.
Читаю инструкцию:
Код: выделить все
 Go to phpBB directory.

      cd ./phpBB3

    If you are upgrading from previous version of the module, you may restore the original
    phpBB source files from previous patch.

      patch -p0 -R < phpBB-embed-3.0.5.patch   
     
    Patch phpBB. Choose appropriate filename for your version of phpBB.

      patch -p0 < phpBB-embed-3.0.5.patch


Чето я не пойму, что за команда "патч"? Это для юниксовых систем чтоли?
Собсно у меня стоит денвер и я на нем эксперементирую, денвер в винХР.
Никакие команды:
Код: выделить все
Z:\home\Drupal\www\phpBB3>patch -p0 < phpBB-embed-3.0.5.patch
"patch" не является внутренней или внешней
командой, исполняемой программой или пакетным файлом.

не проходят.
Что и как нужно сделать? Не пойму....
zverushka

 

Сообщение 15 ноя 2009, 00:38

я тоже так и не смог этот шаг выполнить :oops:
выручила сборка с уже пропатченными файлами, она где-то здесь лежит...

Кстати - инструкцию эту до конца выполнять, как я понял, не стоит. Не нужно добавлять в друпал алиасы для форума, глючить это всё начинает. И не надо во фрейме форум запускать. А в остальном - всё прекрасно работает.
SvS
Активный участник
 
Сообщений: 58
Зарегистрирован:
21 сен 2009, 23:44
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 15 ноя 2009, 14:12

zverushka писал(а):От блин.
Пытаюсь все делать по инструкции этого модуля. Дошла до третьей части, то есть патча.
Читаю инструкцию:
Код: выделить все
 Go to phpBB directory.

      cd ./phpBB3

    If you are upgrading from previous version of the module, you may restore the original
    phpBB source files from previous patch.

      patch -p0 -R < phpBB-embed-3.0.5.patch   
     
    Patch phpBB. Choose appropriate filename for your version of phpBB.

      patch -p0 < phpBB-embed-3.0.5.patch


Чето я не пойму, что за команда "патч"? Это для юниксовых систем чтоли?
Собсно у меня стоит денвер и я на нем эксперементирую, денвер в винХР.
Никакие команды:
Код: выделить все
Z:\home\Drupal\www\phpBB3>patch -p0 < phpBB-embed-3.0.5.patch
"patch" не является внутренней или внешней
командой, исполняемой программой или пакетным файлом.

не проходят.
Что и как нужно сделать? Не пойму....


Да, команда patch - это команда для ОС Linux.
Под Windows есть какая-то программка, но я не знаю какая...
Скачайте уже пропатченый форум из этой ветки, я его выкладывал. Думаю, что так, будет куда проще :)
Не пробуй! Делай или не делай! Нет слова "Попытка"!
mr_james
Активный участник
 
Сообщений: 56
Зарегистрирован:
03 фев 2009, 14:48
Откуда:
Большой Камень, Приморский край
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 16 дек 2009, 16:47

Господа, а как бы обновиться до phpBB-3.0.6?
Petro

 


Вернуться в Интеграция и конвертирование

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама