Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Модификация phpBB 3.0.x

Проблема с установкой User Mod Blog

Расширение функциональности phpBB 3.0.x. Создание и использование модов
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке модов

Сообщение 21 мар 2014, 11:10

Проблема в последнем пункте:

DIY Instructions

These are manual instructions that cannot be performed automatically. You should follow these instructions carefully.

Go to yoursite/blog/database.php in your web browser to install the database section.

Set the user/group permissions and configuration settings.

Т.е. идем в браузер, после своего домена дописываем /blog/database.php и должны внестись изменения в базу данных. Но почему-то выскакивает вот такое сообщение:

Общая ошибка
Please download the latest UMIL (Unified MOD Install Library) from: phpBB.com/mods/umil

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/blog/database.php
LINE: 24
CALL: trigger_error()

И как с этим быть? Подскажите, что я не так сделал?
razorg1991
Новичок
 
Сообщений: 6
Зарегистрирован:
20 мар 2014, 23:11
Благодарил (а): 2 раз.
Поблагодарили: 0 раз.

Сообщение 21 мар 2014, 12:10

razorg1991 писал(а):Please download the latest UMIL (Unified MOD Install Library) from: phpBB.com/mods/umil

Пожалуйста скачайте последнюю версию UMIL (Unified MOD Install Library) с сайта: phpBB.com/mods/umil
crash
Поддержка
 
Сообщений: 11348
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 21 мар 2014, 23:11

Ну вроде установился и UMIL и USER MOD BLOG
Необычно конечно, что для установки одного мода нужно установить другой :D
razorg1991
Новичок
 
Сообщений: 6
Зарегистрирован:
20 мар 2014, 23:11
Благодарил (а): 2 раз.
Поблагодарили: 0 раз.

Сообщение 21 мар 2014, 23:15

Когда будешь устанавливать какой нибудь мод, где присутсвует папка UMIL, не заменяй свою той что в моде. Держи на своем форуме актуальную версию
Viktor.Bakumtsev
Наш человек
 
Сообщений: 324
Зарегистрирован:
24 апр 2012, 09:22
Благодарил (а): 1 раз.
Поблагодарили: 41 раз.

СообщениеСообщение было удалено | удалил: Viktor.Bakumtsev | 21 мар 2014, 23:19.

Сообщение 22 мар 2014, 05:56

@razorg1991
то есть вас не удивляет что в винде для игр надо установить directX, в линуксе одна программа может зависеть от другой? :)
А umil это не мод, а типа библиотеки, для работы модов. Так бы в моде каждом пришлось делать что-то типа umil, а так есть общее :)
crash
Поддержка
 
Сообщений: 11348
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 22 мар 2014, 22:44

crash писал(а):@razorg1991
то есть вас не удивляет что в винде для игр надо установить directX, в линуксе одна программа может зависеть от другой? :)
А umil это не мод, а типа библиотеки, для работы модов. Так бы в моде каждом пришлось делать что-то типа umil, а так есть общее :)


Так а почему бы тогда это общее не зашить непосредственно в движок?
razorg1991
Новичок
 
Сообщений: 6
Зарегистрирован:
20 мар 2014, 23:11
Благодарил (а): 2 раз.
Поблагодарили: 0 раз.

Сообщение 23 мар 2014, 07:31

@razorg1991
Почему тогда все существующие моды не зашить сразу в движок?
crash
Поддержка
 
Сообщений: 11348
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 23 мар 2014, 22:32

crash писал(а):@razorg1991
Почему тогда все существующие моды не зашить сразу в движок?


все не нужны, потому как не все ими пользуются. А вот основные библиотеки (или как в PHPBB их тоже называют модулями) можно было бы и положить в коробку.
Я просто долгое время работал на JOOMLA и там такого не было. Т.е. все модули используют непосредственно ее библиотеки и фреймворк.

И я считаю что это правильно! :D
razorg1991
Новичок
 
Сообщений: 6
Зарегистрирован:
20 мар 2014, 23:11
Благодарил (а): 2 раз.
Поблагодарили: 0 раз.

Сообщение 24 мар 2014, 11:41

@razorg1991
возможно когда все моды будут использовать umil, то его включат в дистрибутив
crash
Поддержка
 
Сообщений: 11348
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.


Вернуться в Модификация phpBB 3.0.x

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 9

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
авторов модов
разработчиков скинов
русификаторов
и всех поклонников phpBB3