Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Модификация phpBB 3.0.x » Моды каталога

SEO Mod

Обсуждение и поддержка модов, размещённых в каталоге
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке модов

Сообщение 26 янв 2009, 17:09

Название мода: SEO Mod
Версия мода: 1.0.0
Автор: Handyman
Язык: English
Сложность установки: Средняя
Длительность установки: 15
Сборка форума с этим модом: Перейти

Описание:
Мод для преобразования URL'ов в статичный вид с целью SEO-оптимизации форума.

Страница в каталоге модов: Перейти
Раздел каталога модов: Перейти
Размер архива: 33 Kb
mod_robot
Активный участник
 
Сообщений: 60
Зарегистрирован:
18 янв 2009, 15:05
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 21 июн 2013, 17:12

у меня 2 вопроса (проблемы) форум phpbb3.0.11 скачал на Вашем форуме(сборка с порталом благодарностями и т.п.)
Изображение
1 - когда нажимаешь на называние темы ..на рисунке 1..преходит на ссылку + ещё добавляет "-", в итоге переход на несуществующую страницу,.. как и где это исправить (не могу понять)?
2 - можно ли избавиться от этих добавочных символов , в данном примере t3 (если это конечно не повлияет на работу форума)
Заранее спасибо за помощь :)
admin77
Новичок
 
Сообщений: 9
Зарегистрирован:
21 июн 2013, 17:02
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 22 июн 2013, 13:32

что сайт не обслуживается? хоть скажите в каком файле искать что бы убрать доп "-" .... view_topic? там уж с ориентируюсь на местности, мод ставлю 4 ый раз..и каждый раз одно и то же)
admin77
Новичок
 
Сообщений: 9
Зарегистрирован:
21 июн 2013, 17:02
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 16 июл 2013, 17:51

убрал просто в .htaccess "-" и вопрос выше решился сам собой. (это ппц не уж то автор так мог ошибиться..или сделано специально?что бы жизнь сказкой не казалась...)
теперь вторая проблема осталось не решенной
когда на главной странице форума жмешь на последнее сообщение из раздела выдает ошибку
Код: выделить все
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb3_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 435' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb3_posts p phpbb3_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 435

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_seo.php
LINE: 164
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/viewtopic.php
LINE: 67
CALL: moved_topic()

что делать? dbal не трогал...где копать ошибку. может кто встречался с такой ошибкой?
запрос к Бд делал по рабочему префиксу phpbb3_
admin77
Новичок
 
Сообщений: 9
Зарегистрирован:
21 июн 2013, 17:02
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 17 июл 2013, 19:10

@admin77

В файле includes/functions_seo.php найдите
Код: выделить все
      else
      {
         $sql = 'SELECT t.topic_title
            FROM ' . POSTS_TABLE . ' p
               ' . TOPICS_TABLE . " t
            WHERE t.topic_id = p.topic_id
               AND t.topic_id = $id";
         $newid = "p$id";
      }
      $result = $db->sql_query($sql);
и после
Код: выделить все
FROM ' . POSTS_TABLE . ' p
добавьте запятую.
Аватар пользователя
serjan
Разработчик модов
 
Сообщений: 480
Зарегистрирован:
12 янв 2009, 19:18
Благодарил (а): 0 раз.
Поблагодарили: 4 раз.

Сообщение 19 июл 2013, 10:24

admin77 писал(а):когда нажимаешь на называние темы ..на рисунке 1..преходит на ссылку + ещё добавляет "-", в итоге переход на несуществующую страницу,.. как и где это исправить (не могу понять)?


таже фигня. Случайно обнаружил эту багу когда в Яндекс.Метрике увидел, что 30% страниц "исключено роботом" из-за ошибки "HTTP-статус: Ресурс не найден (404)"

А как вы убрали "-" через .htaccess? Что там нужно прописать?

serjan писал(а):@admin77

В файле includes/functions_seo.php найдите ... добавьте запятую.

Запятую добавил. Теперь возникает ошибка (404) при попытке перехода по ссылке типа http://мой-сайт.ru/viewtopic.php?f=2&p=921#p921
alex_777
Новичок
 
Сообщений: 3
Зарегистрирован:
19 июл 2013, 10:14
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

СообщениеСообщение было удалено | удалил: weerdsa | 25 июл 2013, 14:06.

Сообщение 26 июл 2013, 01:09

когда проблема разрешилась, то другая обнаружилась ..потом другая...и я отказался от мода. Поставил сео юльтиматум мод, тот встал более удачно (с некоторыми не дотачетами :D ..лишние 2 слеша..зато все остальное работает на ура )
admin77
Новичок
 
Сообщений: 9
Зарегистрирован:
21 июн 2013, 17:02
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 30 июл 2013, 15:57

admin77 писал(а):когда проблема разрешилась, то другая обнаружилась ..потом другая...и я отказался от мода. Поставил сео юльтиматум мод, тот встал более удачно (с некоторыми не дотачетами :D ..лишние 2 слеша..зато все остальное работает на ура )


Поставил MOD "благодарности за сообщения", тот не стал работать, опять какая-то фигня со ссылками. Устал бороться с этим модом, тоже снес.
Что за " сео юльтиматум мод", можно ссылку? Есть под 3.11?
Нашел ultimate-seo, но там последняя 0.7.0 версия с поддержкой 3.10 и выше, неруссифицированная.
alex_777
Новичок
 
Сообщений: 3
Зарегистрирован:
19 июл 2013, 10:14
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 30 июл 2013, 20:15

alex_777 писал(а):неруссифицированная.

ну так сами для себя русифицируйте
crash
Поддержка
 
Сообщений: 11345
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 06 окт 2013, 22:50

Добрый вечер, господа!
Снова проблема с этим модом( Будьте добры, подскажите что делать.
Долгое время не замечал, но не работает RSS, точнее RSS работает, но ведет на несуществующие страницы и редирект через .htacces не проиходит(
RSS ведет на адреса типа: site.ru/viewtopic.php?p=615#p615
ну а там:
General Error
SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 615' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb_posts p phpbb_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 615

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_seo.php
LINE: 164
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/viewtopic.php
LINE: 72
CALL: moved_topic()
weerdsa
Новичок
 
Сообщений: 8
Зарегистрирован:
06 ноя 2012, 09:40
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.


Вернуться в Моды каталога

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
авторов модов
разработчиков скинов
русификаторов
и всех поклонников phpBB3