Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Сборки phpBB 3.0.x » Обсуждение сборок от BB3x.ru

Проблема с галереей (сборка Expand )

Если у Вас возникли вопросы по сборкам, Вы можете обсудить их в этом форуме.

Сообщение 24 дек 2013, 09:41

Доброго дня. На хостинге при заходе в галерею выдал ошибку
Fatal error: Class 'phpbb_gallery' not found in /home/xnfaialu/public_html/gallery/index.php on line 20.
(До этого опробовал сборку на локальном компьютере, всё отлично работало)

----***
define('IN_PHPBB', true);
$phpEx = substr(strrchr(__FILE__, '.'), 1);
include('common.' . $phpEx);
include($phpbb_root_path . 'common.' . $phpEx);

phpbb_gallery::setup(array('mods/gallery')); // строка №20
phpbb_gallery_url::_include('functions_display', 'phpbb');
----*****
То есть класс должен быть описан в файле common.php ?

ps: других ошибок кроме этой не обнаружил. В ЦА все меню галереи отлично работают, слова отображаются по-русски. Версия php 5.3.28 на сервере (по показаниям из ЦА)

Какие действия можно предпринять, чтоб излечить данную ошибку?
NewUser
Пользователь
 
Сообщений: 11
Зарегистрирован:
12 дек 2013, 02:48
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 25 дек 2013, 00:22

На локальном:
При попытке добавить фотографию через "newimage" (админ, создал один альбом, права установил "все да") выводит сообщение, что "Вы исчерпали лимит количества фотографий в альбоме и более не можете их загружать. Свяжитесь с администрацией для получения дополнительных сведений."


-----------------------
Есть ли резон попробовать переустановить сборку, проследить (специально) все ли файлы залились на сервер (вдруг какой-то файл пропустился и поэтому возникла ошибка) ??
Или установить эту-же сборку, но исключить установку галереи, как это хотел сделать товарищ Extazik113 в топике http://bb3x.ru/forum/obsuzhdenie-sborok-ot-bb3x-ru/oshibki-t8139.html
NewUser
Пользователь
 
Сообщений: 11
Зарегистрирован:
12 дек 2013, 02:48
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 26 дек 2013, 14:15

По-поводу проблемы с загрузкой классов скорее всего дело в настройках сервера. Попробуйте связаться с хостером и описать ему проблему.

По-поводу прав проверьте, чтоб у альбома была настоена возможность загружать неограниченное количество фотографий или выставлен лимит отличный от нуля
см. скрин ниже.
Вложения
gallery.png
Аватар пользователя
serjan
Разработчик модов
 
Сообщений: 480
Зарегистрирован:
12 янв 2009, 19:18
Благодарил (а): 0 раз.
Поблагодарили: 4 раз.

Сообщение 16 мар 2014, 23:21

У меня та же проблема.
Вы исчерпали лимит количества фотографий в альбоме и более не можете их загружать
Все параметры установил.
Пробую просто для админа посмотреть, как работает. Пока не получается.
Поставил в правах не 0, а 100. И для группы Администраторы, и прямо для admin.

Что можно еще посмотреть?
avkorn
Новичок
 
Сообщений: 4
Зарегистрирован:
14 мар 2014, 17:17
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 16 мар 2014, 23:28

Кстати, не могу еще и импортировать картинки

Screen Shot 2014-03-16 at 23.23.54.png


Хотя файлы там есть:
Screen Shot 2014-03-16 at 23.25.15.png


Версия PHP Gallery самая последняя.
Сборка Expand.
В чем может быть дело?
avkorn
Новичок
 
Сообщений: 4
Зарегистрирован:
14 мар 2014, 17:17
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 02 сен 2014, 10:36

Здравствуйте :smile: Помогите, если возможно. Проблема такая: нет ссылок на создание альбомов в личном кабинете. Настройки прав доступа выставлены в "да"и в настройках мода включен показ личных альбомов в кабинете. Стоит сборка Expand версии 3.0.12, скачанная с тут. Мод галереи изначально стоял, т.е. я устанавливала только ту часть, которая касалась шаблона (Milky way на основе subsilver). В админке мод виден. а вот в кабинетах нет. Кроме того, выдается ошибка скриптов. Подскажите,плз, что еще проверить?
Вложения
Безымянный1.png
val
Пользователь
 
Сообщений: 22
Зарегистрирован:
16 ноя 2013, 14:31
Благодарил (а): 3 раз.
Поблагодарили: 0 раз.

Сообщение 02 сен 2014, 11:40

кэш стиля, форума чистили/обновляли ?
crash
Поддержка
 
Сообщений: 11308
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 566 раз.

Сообщение 02 сен 2014, 12:07

да, несколько раз
val
Пользователь
 
Сообщений: 22
Зарегистрирован:
16 ноя 2013, 14:31
Благодарил (а): 3 раз.
Поблагодарили: 0 раз.

Сообщение 03 сен 2014, 14:43

Как говориться "Не мешало бы еще раз" :D

По теме:
/forum/gallerey/scripts/top.js - файла не существует, сомневаюсь что в этом проблема, но жизненно важный файл.
А теперь проверьте по пусти (Админка -> Система -> Управление модулями -> Администраторский раздел) есть ли там где-то категория с галереи.
Тогда уже будет виднее, как вы устанавливали модуль.
Mixail_fet
Пользователь
 
Сообщений: 25
Зарегистрирован:
04 янв 2013, 13:20
Благодарил (а): 1 раз.
Поблагодарили: 7 раз.

Сообщение 03 сен 2014, 15:28

Скрипт top.js - это не отсюда, он в скрин за компанию попал. Надо было убрать, каюсь. Ниже то, что хотела показать. А тут: Админка -> Система -> Управление модулями -> Администраторский раздел - все в порядке, модуль отображается и настраивается. В том-то и беда, что на кривую установку грешить не могу, т.к. мод предустановленный.
Вложения
1234.png
1234.png (8.97 KiB) Просмотров: 1192
val
Пользователь
 
Сообщений: 22
Зарегистрирован:
16 ноя 2013, 14:31
Благодарил (а): 3 раз.
Поблагодарили: 0 раз.


Вернуться в Обсуждение сборок от BB3x.ru

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Форум поддержки phpBB
2008 - 2015 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
авторов модов
разработчиков скинов
русификаторов
и всех поклонников phpBB3