Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.1.x » Поддержка phpBB 3.1.x

... не обноляется

Помощь в установке, настройке и использовании phpBB 3.1.x

Сообщение 02 ноя 2014, 17:08

на данный момент имею версию форума 3.0.12,хочу обновить на 3.1... Скачал архив только изменённые файлы +ру ,распаковал,загрузил через фтп перезаписывая старые ,обновил базу данных . В итоге пишет что БД обновлена до последней версии,о сам форум не обновился,причем кидает глобальную ошибку. :( Подскажите пажалста что не так , и как можно решить эту проблему...
sawas
Пользователь
 
Сообщений: 49
Зарегистрирован:
03 окт 2014, 12:59
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 02 ноя 2014, 18:13

@sawas
вашим способом я бы скачал новый форум и просто заменил файлы. Но чтобы не путаться в новых и старых файлах, удалил бы старые кроме папок store, files,images и файла config.php
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 02 ноя 2014, 19:46

вот что из этого палучилось
Код: выделить все
Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "message_body.html" (looked into: ).' in /var/www/vhosts/u2004310.plsk.regruhosting.ru/httpdocs/forum.profitschool.ru/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:202 Stack trace: #0 /var/www/vhosts/u2004310.plsk.regruhosting.ru/httpdocs/forum.profitschool.ru/phpbb/template/twig/loader.php(106): Twig_Loader_Filesystem->findTemplate('message_body.ht...') #1 /var/www/vhosts/u2004310.plsk.regruhosting.ru/httpdocs/forum.profitschool.ru/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(138): phpbb\template\twig\loader->findTemplate('message_body.ht...') #2 /var/www/vhosts/u2004310.plsk.regruhosting.ru/httpdocs/forum.profitschool.ru/vendor/twig/twig/lib/Twig/Environment.php(265): Twig_Loader_Filesystem->getCacheKey('message_body.ht...') #3 /var/www/vhosts/u2004310.plsk.regruhosting.ru/httpdocs/forum.profitschool.ru/vendor/twig/twig/lib/Twig/Environment.php(312): Twig_Environment->getTemplateClass('message_body.ht...', NULL) #4 /var/www/vh in /var/www/vhosts/u2004310.plsk.regruhosting.ru/httpdocs/forum.profitschool.ru/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 202
как с этим бороться ?...
sawas
Пользователь
 
Сообщений: 49
Зарегистрирован:
03 окт 2014, 12:59
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 02 ноя 2014, 20:25

проверить, а есть ли файл на самом деле
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 02 ноя 2014, 20:37

Поступить как вы рекомдавали ,
crash писал(а):скачал новый форум и просто заменил файлы
crash писал(а):удалил бы старые кроме папок store, files,images и файла config.php

обновил БД (обновилась) а с форумом беда :(
может здесь косяк в том ,что у меня тема субсилвер2,а в скаченой сборке этой темы нету ?
sawas
Пользователь
 
Сообщений: 49
Зарегистрирован:
03 окт 2014, 12:59
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 02 ноя 2014, 20:46

@sawas
а сейчас какой форум открывается по адресу forum.profitschool.ru?
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 02 ноя 2014, 20:47

вы можете попробовать в базе указать, чтобы заменять стиль пользователя стилем по-умолчанию.
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 02 ноя 2014, 21:12

а можно по подробнее как это сделать ?
за ранее спасибо.
sawas
Пользователь
 
Сообщений: 49
Зарегистрирован:
03 окт 2014, 12:59
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 02 ноя 2014, 21:16

так а форум какой открывается то?
заходите в базу, таблица phpbb_config и выставляете override_user_style в значение 1. Хотя еще было бы не плохо вообще посмотреть какой стиль выбран по-умолчанию
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 02 ноя 2014, 22:10

так как с версией 3.1 не чего не вышло,форум вообще не открывался а кидало только ошибку про которую писал ниже ,восстановил прежднюю 3.0.12 , и пытаюсь найти решение как обновится до более модифицированной 3.1 ,и при том не потерять БД и всё другое
по умолчанию стоит стиль subsilver2
sawas
Пользователь
 
Сообщений: 49
Зарегистрирован:
03 окт 2014, 12:59
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.


Вернуться в Поддержка phpBB 3.1.x

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама