Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.1.x » Поддержка phpBB 3.1.x

Версия PHP для phpBB3.1.2 ?

Помощь в установке, настройке и использовании phpBB 3.1.x

Сообщение 22 дек 2014, 12:04

Здравствуйте. Сразу говорю, что в работе с phpBB я новичок, так что не пинайте сильно.

Решил попробовать версию 3.1.2 на Денвере, прочитал требования на страничке http://bb3x.ru/d_start/start_demands. Там написано, что требуется версия

Изображение

У меня на Денвере стоит 5.2.12, так что скачал и попробовал поставить. Установка не запустилась, дала ошибку
Warning: Unexpected character in input: '\' (ASCII=92) state=1 in W:\home\phpBB3.test\www\forum\install\index.php on line 110

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in W:\home\phpBB3.test\www\forum\install\index.php on line 110

Parse error: syntax error, unexpected T_STRING in W:\home\phpBB3.test\www\forum\install\index.php on line 110

После небольшой правки файла /install/index.php, он запустился и выдал, что
You are running an unsupported PHP version. Please upgrade to PHP 5.3.3 or higher before trying to install phpBB 3.1


Так где ж всё таки правильно? Какая версия PHP нужна форуму версии 3.1.2?
John
Новичок
 
Сообщений: 1
Зарегистрирован:
22 дек 2014, 11:22
Благодарил (а): 1 раз.
Поблагодарили: 0 раз.

Сообщение 22 дек 2014, 13:55

John писал(а):Какая версия PHP нужна форуму версии 3.1.2?

2. Requirements

phpBB 3.1.x has a few requirements which must be met before you are able to install and use it.

A webserver or web hosting account running on any major Operating System with support for PHP
A SQL database system, one of:
MySQL 3.23 or above (MySQLi supported)
MariaDB 5.1 or above
PostgreSQL 8.3+
SQLite 2.8.2+
SQLite 3.6.15+
MS SQL Server 2000 or above (directly or via ODBC or the native adapter)
Oracle
PHP 5.3.3+ with support for the database you intend to use.
The following PHP modules are required:
json
getimagesize() function must be enabled.
Presence of the following modules within PHP will provide access to additional features, but they are not required:
zlib Compression support
Remote FTP support
XML support
Imagemagick support
GD Support

If your server or hosting account does not meet the requirements above then you will be unable to install phpBB 3.1.x.


John писал(а):Решил попробовать версию 3.1.2 на Денвере, прочитал требования на страничке http://bb3x.ru/d_start/start_demands. Там написано, что требуется версия

Если посмотреть на дату статьи и увидеть что там 2008 год, а тогда версии 3.1.х не было. А значит требование для 3.0.х в данной статье описаны.
crash
Поддержка
 
Сообщений: 11329
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.


Вернуться в Поддержка phpBB 3.1.x

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама