Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Поддержка phpBB 3.0.x

Не воспроизводяться ФАЙЛЫ флэш ави аудио!

Помощь в установке, настройке и использовании phpBB 3.0.x
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке форума, Конвертеры

Сообщение 27 мар 2009, 17:32

При создании расширений и их настройки столккнулся с такой проблемой! Когда закачиваю файл к примеру ави или флэшь файлы то потом при просмотре вложения оно не проигрываеться! Хотя пллер в браузере открываеться но нечего не проигрываеться! что делать! может еще в php.ini покапаться увелить память обрабатываемую форуму! Хелп плиз!
AinF

 

Сообщение 05 мар 2010, 11:12

И тишина, а у меня тоже такая фигня. Потому что src относительная, если её переписать руками на обсолютную, то всё работает. Думал может Prime Links мешается - вроде отключал его, не помогло. Что делать?
Сэр Вант

 

Сообщение 06 мар 2010, 22:01

AinF
Сэр Вант

господа как вы х-отите чтобы все это проигрывалась ???
Мой проект - Urbanwave
Сделано на: phpbb 3.0.7,KTVM portal,Memht portal+моды
http://urbanwave.info - Онлайн радио,тв, форумные игры.
http://cop-mmo.ru/ - WOT сообщество _COP_
Если есть предложения что либо установить-пишите в личку
Аватар пользователя
xC4x
Поддержка
 
Сообщений: 2348
Зарегистрирован:
16 мар 2009, 07:11
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 07 мар 2010, 01:03

xC4x
что значит как? хоть как-нибудь, для начала
Сэр Вант

 

Сообщение 07 мар 2010, 03:44

Сэр Вант писал(а):что значит как? хоть как-нибудь, для начала

Как допустим мп3 попадает на форум : в виде вложения или в виде проигрывания в плеере ???
Мой проект - Urbanwave
Сделано на: phpbb 3.0.7,KTVM portal,Memht portal+моды
http://urbanwave.info - Онлайн радио,тв, форумные игры.
http://cop-mmo.ru/ - WOT сообщество _COP_
Если есть предложения что либо установить-пишите в личку
Аватар пользователя
xC4x
Поддержка
 
Сообщений: 2348
Зарегистрирован:
16 мар 2009, 07:11
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 07 мар 2010, 10:57

в виде вложения, которое должно проигрываться в плеере
Сэр Вант

 

Сообщение 16 мар 2010, 15:56

Сэр Вант

ввиде вложения не будет проигрываться , если не сделаны изменения в коде страницы или не сделаны специфичные ббкоды ;)
Мой проект - Urbanwave
Сделано на: phpbb 3.0.7,KTVM portal,Memht portal+моды
http://urbanwave.info - Онлайн радио,тв, форумные игры.
http://cop-mmo.ru/ - WOT сообщество _COP_
Если есть предложения что либо установить-пишите в личку
Аватар пользователя
xC4x
Поддержка
 
Сообщений: 2348
Зарегистрирован:
16 мар 2009, 07:11
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 18 мар 2010, 16:16

bb коды то работают, но почему же не должны вложения?!
вот же вроде в attachment.html написано штатно:
Код: выделить все
      <!-- IF _file.S_WM_FILE -->
         <!-- method used here from http://alistapart.com/articles/byebyeembed / autosizing seems to not work always, this will not fix -->
         <object width="320" height="285" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" id="wmstream_{_file.ATTACH_ID}">
            <param name="url" value="{_file.U_DOWNLOAD_LINK}" />
            <param name="showcontrols" value="1" />
            <param name="showdisplay" value="0" />
            <param name="showstatusbar" value="0" />
            <param name="autosize" value="1" />
            <param name="autostart" value="0" />
            <param name="visible" value="1" />
            <param name="animationstart" value="0" />
            <param name="loop" value="0" />
            <param name="src" value="{_file.U_DOWNLOAD_LINK}" />
            <!--[if !IE]>-->
и WM открывается же, только не играет
Сэр Вант

 

Сообщение 18 мар 2010, 23:37

Сэр Вант
Есть пара решений, сейчас напишу как:
1) код WMP не верен в корне
Вот правильное - здесь читай : http://www.microsoft.com/windows/windowsmedia/howto/articles/adsolutions2.aspx
Дальше :

Почитать побольше :
а) http://www.mioplanet.com/rsc/embed_mediaplayer.htm
б) http://www.geekpedia.com/tutorial152_Embedding-Windows-Media-Player-into-a-web-page.html
Мой проект - Urbanwave
Сделано на: phpbb 3.0.7,KTVM portal,Memht portal+моды
http://urbanwave.info - Онлайн радио,тв, форумные игры.
http://cop-mmo.ru/ - WOT сообщество _COP_
Если есть предложения что либо установить-пишите в личку
Аватар пользователя
xC4x
Поддержка
 
Сообщений: 2348
Зарегистрирован:
16 мар 2009, 07:11
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 19 мар 2010, 00:11

т.е, другими словами, это баг PHPbb?
упс, сорри, цитата кода не полная
Код: выделить все
      <!-- IF _file.S_WM_FILE -->
         <!-- method used here from http://alistapart.com/articles/byebyeembed / autosizing seems to not work always, this will not fix -->
         <object width="320" height="285" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" id="wmstream_{_file.ATTACH_ID}">
            <param name="url" value="{_file.U_DOWNLOAD_LINK}" />
            <param name="showcontrols" value="1" />
            <param name="showdisplay" value="0" />
            <param name="showstatusbar" value="0" />
            <param name="autosize" value="1" />
            <param name="autostart" value="0" />
            <param name="visible" value="1" />
            <param name="animationstart" value="0" />
            <param name="loop" value="0" />
            <param name="src" value="{_file.U_DOWNLOAD_LINK}" />
            <!--[if !IE]>-->
               <object width="320" height="285" type="video/x-ms-wmv" data="{_file.U_DOWNLOAD_LINK}">
                  <param name="src" value="{_file.U_DOWNLOAD_LINK}" />
                  <param name="controller" value="1" />
                  <param name="showcontrols" value="1" />
                  <param name="showdisplay" value="0" />
                  <param name="showstatusbar" value="0" />
                  <param name="autosize" value="1" />
                  <param name="autostart" value="0" />
                  <param name="visible" value="1" />
                  <param name="animationstart" value="0" />
                  <param name="loop" value="0" />
               </object>
            <!--<![endif]-->
         </object>
Сэр Вант

 


Вернуться в Поддержка phpBB 3.0.x

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама