Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Поддержка phpBB 3.0.x

Проблема со сменой форума

Помощь в установке, настройке и использовании phpBB 3.0.x
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке форума, Конвертеры

Сообщение 15 окт 2009, 09:48

Доброго дня уважаемые.
Возникла проблема, бьюсь уже 4-й день.
Исходные данные: На локальной машине стоит Denwer
MySQL Сервер:
Версия сервера: 5.0.45-community-nt
Версия протокола: 10
MySQL-кодировка: UTF-8 Unicode (utf8)
Веб-сервер
Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8d PHP/5.2.4
Версия MySQL-клиента: 5.0.45
PHP расширение: mysql
phpMyAdmin
Информация о версии: 3.2.2
CMS: Joomla 1.0.0.15
Исходный форум fireboard 2.0 RE

Требуется из форума Fireboard перенести все на phpBB 3. Делаю все следующим образом ставлю форум SMF версии 1.10 и спомощью конвертера переношу все данные из Fireboard в SMF. Все переносится нормально и текст и.т.д. далее ставлю phpBB3 и из SMF переношу с помощью конвертера данные в phpBB3. В результате получаю только кракозябры вместо русских букв. Что в MySQL что в phpBB. пробовал менять кодировки базы на UTF8, cp1251 и koi8r ничего не получилось. Помогите пожалуйста проект стоит. Или может ктото знает другой способ перенести эти сообщения?(кроме ручного копирования)
заранее спасибо.
tlig

 

Сообщение 15 окт 2009, 09:57

форум работает в utf-8
crash
Поддержка
 
Сообщений: 11355
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 569 раз.

Сообщение 15 окт 2009, 10:11

Я это понимаю прекрасно что он работает в UTF-8 просто от безисходности перепробовал уже все, если я просто его ставлю то тестовое сообщение там нормлаьно. А если конвертирую другой форум то получается косяк
tlig

 

Сообщение 15 окт 2009, 10:18

В файле .htaccess добавь вверху adddefaultcharset utf-8
файл в корне www должен быть
если его нет - то создай
soldroman

 

Сообщение 15 окт 2009, 10:21

Таки дело в том что даже при ручном выборе кодировки UTF-8 кракозябры ими и остаются. В заголовке html кода стоит кодировка по умолчанию UTF-8. Да и в руки в .htaccess я пробовал прописывать. не помогает
tlig

 

СообщениеСообщение было удалено | удалил: xC4x | 16 окт 2009, 18:08.
Причина: Задал вопрос - жди ответа !

Сообщение 16 окт 2009, 18:10

tlig
ответ был дан в верхнем посту crash ;)
значит не правильно сконвертировал. проверяй в БД все поля и их кодировку.
Мой проект - Urbanwave
Сделано на: phpbb 3.0.7,KTVM portal,Memht portal+моды
http://urbanwave.info - Онлайн радио,тв, форумные игры.
http://cop-mmo.ru/ - WOT сообщество _COP_
Если есть предложения что либо установить-пишите в личку
Аватар пользователя
xC4x
Поддержка
 
Сообщений: 2348
Зарегистрирован:
16 мар 2009, 07:11
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 17 ноя 2009, 11:57

ОК, если мы в исходных данных имеем что начальный форум Fireboard работал с кодировкой cp1251_general_ci то что надо сделать чтобы все стало нормально? Если пошагово напишете отдельное спасибо будет.
tlig

 


Вернуться в Поддержка phpBB 3.0.x

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама