Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Поддержка phpBB 3.0.x

Проблемы с регистрацией

Помощь в установке, настройке и использовании phpBB 3.0.x
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке форума, Конвертеры

Сообщение 22 июн 2009, 23:04

Здравствуйте!
3 проблемы:
1. Когда пользователь после заполнения формы регистации кликает "отправить", его оставляют на той же странице и над формой появляется надпись о том, что он должен ввести правильный е-мэйл и что ему придет (а на самом деле уже пришло, только об этом не говорится) письмо для поддтверждения регистрации. Народ начинает пробовать вводить другие адреса и повторно заполнять капчу.
2. Те не многие которые догодались заглянуть в ящик, при переходе по ссылки активации попадают на белую страницу (хотя активация срабатывает, то пользователи так же об этом не догадываются) вот с таким урлом http://www.doktorpapa.ru/forum3/ucp.php ... P2GB9LZTJN
3. На такую же белую страницу попадают те, кто нажимайт на ссылку "Выйти".
Обновился до 3.0.5 - то же.
Что делать? Вот ссылка на форум http://www.doktorpapa.ru/forum3/

Да, еще при удалении пользователя на красном фоне высвечивается
"Предупреждение
FORM_INVALID", хотя удаляет. Может это как-то связано с вышеописанным?

С уважением,
Александр
fdzkuz
Пользователь
 
Сообщений: 47
Зарегистрирован:
22 июн 2009, 22:51
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июн 2009, 09:40

fdzkuz
что делали с формумом перед тем, как появились проблемы?
Самая страшная ошибка - это ошибка без конкретных причин и видимых последствий.

Личка и icq - только для личных вопросов. Консультации в личке оказываю только за плату.
Все остальное будет игнорироваться.
Alek$
Поддержка
 
Сообщений: 262
Зарегистрирован:
28 янв 2009, 16:41
Откуда:
Новосибирск
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июн 2009, 11:39

Спасибо, что откликнулись. Перед появлением FORM_INVALID по-моему только удалял в редактаре шаблонов строку с информацией для адреса сайта в ucp_profile_profile_info.html - спамеры замучили, пытался что -то сделать. Строку восстановил, но проблема не исчезла.

Проблемы с регистрацией и выходом заметил только вчера, перед этим установил права всех зарегистрированных пользователей на "ограниченный доступ", для премодерации спам-сообщений, кстати премодерация так и не заработала - под другим логином свободно разместил сообщение. Обновился до 3.0.5 - проблема не изчезла. Еще на сервере повысил php c 4 до 5.

Кроме того, я заметил, что после ввода логина и пароля страница формы не изчезает сразу (а помоему так было раньше), а весит пару секунд с чистыми полями для воода логина и пароля, создается впечатление, что человек не правильно ввел данные. Но это, конечно мелочь.

Еще раз спасибо за поддержку.
fdzkuz
Пользователь
 
Сообщений: 47
Зарегистрирован:
22 июн 2009, 22:51
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июн 2009, 13:38

fdzkuz
что-то странное у вас творится. Давайте ссылку на форум, надо смотреть.

По поводу спамеров - для этого существуют специальные моды, например Anti Bot Question.
Самая страшная ошибка - это ошибка без конкретных причин и видимых последствий.

Личка и icq - только для личных вопросов. Консультации в личке оказываю только за плату.
Все остальное будет игнорироваться.
Alek$
Поддержка
 
Сообщений: 262
Зарегистрирован:
28 янв 2009, 16:41
Откуда:
Новосибирск
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июн 2009, 14:01

Спасибо, вот http://www.doktorpapa.ru/forum3/
Такое ощущение что не работает перенаправление в файле ucp.php после регистрации, активации и выхода из форума.
Пришлось в письме после ссылки активации большими буквами написать про белое окно :)
Думаю это ручные спамеры, капча-то стоит.
fdzkuz
Пользователь
 
Сообщений: 47
Зарегистрирован:
22 июн 2009, 22:51
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июн 2009, 14:20

fdzkuz
боты капчу уже давно пробивают.

Что именно у вас сломано сложно сказать, скорее всего вы где-то накосячили при обновлении. Модов у вас вроде бы не установлено, поэтому советую просто перезалить все файлы из оригинального дистрибутива, включая русские языковые файлы
Самая страшная ошибка - это ошибка без конкретных причин и видимых последствий.

Личка и icq - только для личных вопросов. Консультации в личке оказываю только за плату.
Все остальное будет игнорироваться.
Alek$
Поддержка
 
Сообщений: 262
Зарегистрирован:
28 янв 2009, 16:41
Откуда:
Новосибирск
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 23 июн 2009, 15:06

Ощибка была еще до обновления. Но похоже другого выхода нет, ночью переустановлю. Спасибо за поддрежку и Anti Bot Question :)
fdzkuz
Пользователь
 
Сообщений: 47
Зарегистрирован:
22 июн 2009, 22:51
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 24 июн 2009, 04:59

Здравствуйте, еще раз. Переустановил форум, добавил мод.
Все ошибки остались и форма мода не выводится на страницу регистрации (я правда в саблильвере не редактировал - у меня просильвер стоит, но ведь должно быть все в порядке?).

Как переустанавливал: залил файлы в новую папку, форум со старой папкой удалил, подключил новый форум к старой базе с новым префиксом. После установки в конфиге поменял префикс на старый (может нельзя было так?) - все заработало, но со старыми ошибками.

В моде тоже установил правильный префикс. Думаю что, форма с вопросом не выводится из-за файлов ucp.php, с которыми связан мод и с работой которых видимо связанны описанные выше ошибки при регистрации, активации и выходе. Ведь выбода антибота кроме редактирования файлов и запроса к базе больше ничего делать не надо? Ничего активировать в админке или добавлять новые файлы, помимо тех, что редактируешь?

Пришлось как временное решения извратиться с обращениями к пользователям при регистрации и активации, чтобы они понимали последовательность действий.

Всю ночь просидел, блин - безрезультатно. Можно, конечно, вообще все с нуля и с нулевой базой сделать, а потом импортировать старую базу из дампа. Но что-то мне кажется, что результат будет тем же. Что делать? Помогите, пожалуйста.
fdzkuz
Пользователь
 
Сообщений: 47
Зарегистрирован:
22 июн 2009, 22:51
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 24 июн 2009, 09:04

fdzkuz
пришлите в личку ftp доступ к сайту, сегодня-завтра посмотрю детально, в чем дело.
Самая страшная ошибка - это ошибка без конкретных причин и видимых последствий.

Личка и icq - только для личных вопросов. Консультации в личке оказываю только за плату.
Все остальное будет игнорироваться.
Alek$
Поддержка
 
Сообщений: 262
Зарегистрирован:
28 янв 2009, 16:41
Откуда:
Новосибирск
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.

Сообщение 27 июн 2009, 09:55

Детальный разбор показал: на хостинге не работает функция error_reporting() - уровень отображения ошибок она не меняет.

Отчасти решить проблему можно следующим образом:
В файле includes/functions.php найти
Код: выделить все
   // Do not display notices if we suppress them via @
   if (error_reporting() == 0)

И заменить на
Код: выделить все
   // Do not display notices if we suppress them via @
   if (error_reporting() == 0 && !in_array($errno, array(E_USER_WARNING, E_USER_NOTICE, E_USER_ERROR)))
Самая страшная ошибка - это ошибка без конкретных причин и видимых последствий.

Личка и icq - только для личных вопросов. Консультации в личке оказываю только за плату.
Все остальное будет игнорироваться.
Alek$
Поддержка
 
Сообщений: 262
Зарегистрирован:
28 янв 2009, 16:41
Откуда:
Новосибирск
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.


Вернуться в Поддержка phpBB 3.0.x

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 7

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама