Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Поддержка phpBB 3.0.x

Вид последних сообщений на главной форума.

Помощь в установке, настройке и использовании phpBB 3.0.x
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке форума, Конвертеры

Сообщение 28 ноя 2013, 11:20

crash писал(а):похоже у вас в стиле нет папки ru с файлами или это старые логи? :)


Вот сдесь?

1.JPG


Что-то нужно исправить?

Я пробую ставить сначала вот на этот http://segamer.ru/ , а потом на тот, что в профиле указан.
34RUS
Пользователь
 
Сообщений: 38
Зарегистрирован:
27 ноя 2013, 09:10
Откуда:
Волгоградская область
Благодарил (а): 4 раз.
Поблагодарили: 0 раз.

Сообщение 28 ноя 2013, 11:22

все правильно. В какой момент ошибка то вылазит?
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 28 ноя 2013, 11:23

Получилось, но вот такая байда в админке(((

На главной название темы появилось)))

1.JPG
34RUS
Пользователь
 
Сообщений: 38
Зарегистрирован:
27 ноя 2013, 09:10
Откуда:
Волгоградская область
Благодарил (а): 4 раз.
Поблагодарили: 0 раз.

Сообщение 28 ноя 2013, 11:27

в папке languages/ru надо пересохранить файл info_acp_altt.php в кодирвоке utf-8 без ВОМ. Сейчас файл в кодировке windows-1251, что неправильно
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 28 ноя 2013, 11:36

crash писал(а):в папке languages/ru надо пересохранить файл info_acp_altt.php в кодирвоке utf-8 без ВОМ. Сейчас файл в кодировке windows-1251, что неправильно


Всё поправил, спасибо огромное!
34RUS
Пользователь
 
Сообщений: 38
Зарегистрирован:
27 ноя 2013, 09:10
Откуда:
Волгоградская область
Благодарил (а): 4 раз.
Поблагодарили: 0 раз.

Сообщение 28 ноя 2013, 13:49

При установке мода "Отображение подфорумов в столбик" всё сделал по инструкции в админке форума поле для указания кол-ва колонок появилось, но при нажатии на (отправить) выходит ошибка.

Общая ошибка
SQL ERROR [ mysqli ]

Unknown column 'forum_subforumslist_type' in 'field list' [1054]

SQL

UPDATE phpbb_1forums SET parent_id = 2, forum_type = 1, forum_status = 0, forum_parents = '', forum_name = 'Читы «World of Tanks»', forum_link = '', forum_desc = '', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = '', forum_image = '', forum_style = 0, display_subforum_list = 1, forum_subforumslist_type = 0, display_on_index = 1, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 1, enable_prune = 0, prune_days = 7, prune_viewed = 7, prune_freq = 1, forum_flags = 112 WHERE forum_id = 3

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 1238
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 189
CALL: acp_forums->update_forum_data()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_forums->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()


Я опять что-то накосячил с базой?
А точнее я наверное не правильно сделал пункт:
SQL
Code:Select All
ALTER TABLE phpbb_forums ADD forum_subforumslist_type TINYINT(4) DEFAULT '0';
34RUS
Пользователь
 
Сообщений: 38
Зарегистрирован:
27 ноя 2013, 09:10
Откуда:
Волгоградская область
Благодарил (а): 4 раз.
Поблагодарили: 0 раз.

Сообщение 28 ноя 2013, 14:00

34RUS писал(а):А точнее я наверное не правильно сделал пункт:

если вы делали тупо копи пастом, то не правильно. у вас таблица называется phpbb_1forums
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 28 ноя 2013, 14:04

crash писал(а):
34RUS писал(а):А точнее я наверное не правильно сделал пункт:

если вы делали тупо копи пастом, то не правильно. у вас таблица называется phpbb_1forums


Да я просто скопировал и вставил в SQL, что теперь делать??? Как исправить?
34RUS
Пользователь
 
Сообщений: 38
Зарегистрирован:
27 ноя 2013, 09:10
Откуда:
Волгоградская область
Благодарил (а): 4 раз.
Поблагодарили: 0 раз.

Сообщение 28 ноя 2013, 14:09

эх...
выполнить
Код: выделить все
ALTER TABLE phpbb_1forums ADD forum_subforumslist_type TINYINT(4) DEFAULT '0';
crash
Поддержка
 
Сообщений: 11335
Зарегистрирован:
27 янв 2009, 03:22
Благодарил (а): 1 раз.
Поблагодарили: 568 раз.

Сообщение 28 ноя 2013, 14:14

crash писал(а):эх...
выполнить
Код: выделить все
ALTER TABLE phpbb_1forums ADD forum_subforumslist_type TINYINT(4) DEFAULT '0';


crash спасибо! Ну Вы уж извините меня, что я так надоедаю, но не всё получается(((
34RUS
Пользователь
 
Сообщений: 38
Зарегистрирован:
27 ноя 2013, 09:10
Откуда:
Волгоградская область
Благодарил (а): 4 раз.
Поблагодарили: 0 раз.


Вернуться в Поддержка phpBB 3.0.x

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: Google [Bot] и гости: 18

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
+ 17 предустановленных модов
+ SEO-оптимизация форума
+ авторизация через соц. сети
+ защита от спама