Центр пользователя  |  Ваши сообщения  |  FAQ
Форум поддержки phpBB » phpBB 3.0.x » Стили phpBB 3.0.x » Решение проблем со стилями

Установка модов в Hestia Blue

Обсуждение проблем верстки шаблонов и стилизации форума.
Пожалуйста, помните, что существуют: Поиск, Правила форума
Возможно, ответ на Ваш вопрос уже имеется: Документация, Статьи, Накопленный опыт
Полезные материалы по этой теме: Инструкция по установке стиля, Статьи по стилизации phpBB3

Сообщение 10 янв 2010, 20:46

Доброго времени суток, уважаемые гуру. Собственно вопрос. Использую Вашу сборку 3.0.6 Expand и стиль Hestia Blue. Скачал все моды, собранные в сборке и пытаюсь установить их в стиль Hestia Blue. т.к. стиль основан на subsilver2, провожу все правки кода, но мод не отображается (((

Вот вся последовательность действий. На примере NV_recent_topics

Код: выделить все
  <action-group>
    <copy>
      <file from="styles/subsilver2/recent_topics_body.html" to="style/subsilver2/template/recent_topics_body.html" />
    </copy>
    <open src="styles/subsilver2/template/index_body.html">
      <edit>
        <find><![CDATA[<!-- INCLUDE forumlist_body.html -->]]></find>
        <action type="before-add"><![CDATA[<!-- IF RT_DISPLAY --><!-- INCLUDE recent_topics_body.html --><!-- ENDIF -->]]></action>
      </edit>
    </open>
    <diy-instructions lang="en-gb">After Installation go to the acp-module "mods" > "recent topics" to make adjustments</diy-instructions>
    <diy-instructions lang="de">Nach der Installation kannst du im ACP unter "MODS" > "aktuelle Themen" die Einstellungen vornehmen</diy-instructions>
  </action-group>

открываю styles/hestia blue/template/index_body.html
нахожу
Код: выделить все
<!-- INCLUDE forumlist_body.html -->


Вот фрагмент кода
Код: выделить все
<!-- INCLUDE overall_header.html -->

<!-- IF U_MCP -->
   <div id="pageheader">
      <p class="linkmcp">[ <a href="{U_MCP}">{L_MCP}</a> ]</p>
   </div>

   <br clear="all" /><br />
<!-- ENDIF -->

<!-- INCLUDE forumlist_body.html -->

<!-- IF not S_IS_BOT or U_TEAM -->
    <span class="gensmall"><!-- IF not S_IS_BOT --><a href="{U_DELETE_COOKIES}">{L_DELETE_COOKIES}</a><!-- IF U_TEAM --> | <!-- ENDIF --><!-- ENDIF --><!-- IF U_TEAM --><a href="{U_TEAM}">{L_THE_TEAM}</a><!-- ENDIF --></span><br />
<!-- ENDIF -->

<br clear="all" />

<!-- INCLUDE breadcrumbs.html -->


добавляю туда
Код: выделить все
<!-- IF RT_DISPLAY --><!-- INCLUDE recent_topics_body.html --><!-- ENDIF -->


Получаем вот такой код
Код: выделить все
<!-- INCLUDE overall_header.html -->

<!-- IF U_MCP -->
   <div id="pageheader">
      <p class="linkmcp">[ <a href="{U_MCP}">{L_MCP}</a> ]</p>
   </div>

   <br clear="all" /><br />
<!-- ENDIF -->

<!-- IF RT_DISPLAY --><!-- INCLUDE recent_topics_body.html --><!-- ENDIF -->
<!-- INCLUDE forumlist_body.html -->

<!-- IF not S_IS_BOT or U_TEAM -->
    <span class="gensmall"><!-- IF not S_IS_BOT --><a href="{U_DELETE_COOKIES}">{L_DELETE_COOKIES}</a><!-- IF U_TEAM --> | <!-- ENDIF --><!-- ENDIF --><!-- IF U_TEAM --><a href="{U_TEAM}">{L_THE_TEAM}</a><!-- ENDIF --></span><br />
<!-- ENDIF -->

<br clear="all" />

<!-- INCLUDE breadcrumbs.html -->


Вробе бы ничего супер сложно. Очищаю кэш, и специально не копирую файл template\recent_topics_body.html в папку hestia blue.
Запускаю локальный сервер, захожу на форум, получаю ошибку
Общая ошибка
template->_tpl_load_file(): File ./styles/hestia_blue/template/recent_topics_body.html does not exist or is empty

т.е. по сути измененный код работает.

Теперь копирую этот файл и вновь очищаю кэш. Обновляю страницу в IE и мод НЕ РАБОТАЕТ, последние темы не отображаются.
.jpg


Захожу в центр пользователя, меняю тему на subsilver2 - отображаются....

Та же фигня и со всеми остальными модами, пробовал изменить блок в portal3 - не меняется, я очищаю кэш, полностью удаляю код блока, заменяя его на
Код: выделить все
<p>test block</p>
непонятно почему, но блок отображается по прежнему....

Я даже попробовал скопировать index_body из subsilver2 в папку hestia blue...вид форума немного поменялся, но по прежнему упорно не отображается....

Каждый раз я очищаю кэш в админке, а остальное добиваю руками из папки cache. Все настройки по умолчанию. Хэлп ми плиззз....
Последний раз редактировалось Triplex 10 янв 2010, 21:01, всего редактировалось 1 раз.
Triplex

 

Сообщение 10 янв 2010, 20:49

Забыл добавить. Виртуальный сервер использую TopServer и бравзер IE7
Triplex

 


Вернуться в Решение проблем со стилями

 


  • Похожие темы
    Ответов
    Просмотров
    Последнее сообщение

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

Форум поддержки phpBB
2008 - 2017 © BB3x.ru - русская поддержка форума phpBB3
Создано на основе phpBB® Forum Software © phpBB Group
авторов модов
разработчиков скинов
русификаторов
и всех поклонников phpBB3