Страница 1 из 5

Forum Statistics

СообщениеДобавлено: 21 янв 2009, 21:32
mod_robot
Название мода: Forum Statistics
Версия мода: 0.3.0 (beta 4)
Автор: TheUniqueTiger
Автор русификации: GSC
Язык: English
Сложность установки: Средняя
Длительность установки: 25 мин.
Сборка форума с этим модом: Перейти

Описание:
Отображает большое количество статистических данных по работе форума.

Страница в каталоге модов: Перейти
Раздел каталога модов: Перейти
Размер архива: 102 Kb

Re: Forum Statistics

СообщениеДобавлено: 05 фев 2009, 12:16
schel4ok
все установил вроде нармально, но при нажатии на ссылку статистика автоматически происходит logout и соответственно появляется сообщение:
У вас нет доступа в эту часть форума.

а в стиле subsilver2 вообще нет ссылки на страницу статистики

Re: Forum Statistics

СообщениеДобавлено: 06 фев 2009, 10:00
Alek$
schel4ok
в стиле subsilver ссылки нет, потому что вы ее там не добавили. А логаут скорее всего происходит из-за неправильных настроек кукисов.

Re: Forum Statistics

СообщениеДобавлено: 06 фев 2009, 11:44
schel4ok
все разобрался - работает.
но потом поставил аддон User Online Time, который при вызове страницы статистика -> пользователи вызывает ошибку sql запроса.
насколько я понял, ошибка связана с тем, что в инструкции по установке в файле includes/functions_fs.php есть запрос к полю user_online_time в таблице phpbb_users
то есть надо создать дополнительное поле времени в базе данных
мне только не понятно как это поле настроить: какой тип поля time, timestamp или другой и какие дополнительные аттрибуты


//addon User Online Time
case 'online_time':
$sql = 'SELECT user_id as u_id, username, user_colour AS u_colour, user_online_time FROM ' . USERS_TABLE . ' WHERE user_type IN (' . USER_NORMAL . ', ' . USER_FOUNDER . ') ORDER BY user_online_time ' . $order . ', username_clean ASC';

СообщениеДобавлено: 21 апр 2009, 11:18
Olejka_
Подскажите, пожалуйста...
При нажатии на ссылку "Статистика" мне выдается "Parse error: syntax error, unexpected '=', expecting ')' in /home/demobb3x/public_html/sb1/includes/functions_fs.php on line 1137"

Точно такая же строка возникает и на вашем тестовом форуме (Сборка №1).

СообщениеДобавлено: 21 апр 2009, 12:30
serjan
В includes/functions_fs.php замените
Код: выделить все
function get_profile_field_data($profile_field, &$total_values_set, $limit_count = 0, &$total_groups = 0)
на
Код: выделить все
function get_profile_field_data($profile_field, &$total_values_set, $limit_count = 0, &$total_groups)

Re: Forum Statistics

СообщениеДобавлено: 21 апр 2009, 13:06
Olejka_
Спасибо!
Помогло!

Re: Forum Statistics

СообщениеДобавлено: 29 апр 2009, 21:08
alldes
Форум п кодировке UTF-8 а когда захожу в статистику все в кирилице, подскажите как сделать чтобы все было в utf-8

Re: Forum Statistics

СообщениеДобавлено: 05 май 2009, 11:54
Gemini_13
alldes, я делал в Notepad++...
1. Открываем файл
2. Выделяем всё содержимое (Ctrl+A)
3. меняем кодировку на UTF-8
4. Вставляем с буфера
5. Меняем кодировку на ANSI

Вы увидите каракули, но это нормально, на форуме все будет нормально.

Re: Forum Statistics

СообщениеДобавлено: 26 май 2009, 05:13
Cashish
1. В файле fs_activity.php необходимо заменить $curent_title на $curent_topic по всему файлу.
2. При отсутствии опросов выдает:
Код: выделить все
[phpBB Debug] PHP Notice: in file /includes/fs/fs_activity.php on line 113: Undefined offset: 0

3. При отсутствии специальных званий выдает:
[phpBB Debug] PHP Notice: in file /includes/fs/fs_activity.php on line 384: Undefined index: normal

Это пока то, что нашел из багов