Страница 1 из 1

Ошибка не загружается страница

СообщениеДобавлено: 27 сен 2009, 22:08
vit1986
Здравствуйте. Не давно поставил форум phpBB3 версии 3.0.5.
Начал создавать разделы и форумы на нем. Добавил ранги, галлерею аватаров. Ну все такое, чего не было на форуме и легко можно добавить.... Потом добавил мод. Не помню как он называется. Но установка его уровня "легкая". (суть мода в том, что при регистрации нового пользователя на форуме письмо регистраци отсылается не только самому пользователю, но и админу сайта. Нашел этот мод на Вашем сайте.) :) Полезная штука. И все бы не чего. Все нормально работало до сегодняшнего дня. Сегодня решил зайти и проверить "Центр пользователя" все разделы работают нормально, кроме одного.
При выборе раздела "Личные сообщения" и "Создать сообщение" появляется ошибка сверху перед сагрузкой самого форума.


Код ошибки:"{ $error[] = $user->lang['PM_USERS_REMOVED_NO_PM']; } } } } /** * Build the hidden field for the recipients. Needed, as the variable is not read via request_var. */ function build_address_field($address_list) { $s_hidden_address_field = ''; foreach ($address_list as $type => $adr_ary) { foreach ($adr_ary as $id => $field) { $s_hidden_address_field .= ''; } } return $s_hidden_address_field; } /** * Return number of private message recipients */ function num_recipients($address_list) { $num_recipients = 0; foreach ($address_list as $field => $adr_ary) { $num_recipients += sizeof($adr_ary); } return $num_recipients; } /** * Get number of 'num_recipients' recipients from first position */ function get_recipients($address_list, $num_recipients = 1) { $recipient = array(); $count = 0; foreach ($address_list as $field => $adr_ary) { foreach ($adr_ary as $id => $type) { if ($count >= $num_recipients) { break 2; } $recipient[$field][$id] = $type; $count++; } } return $recipient; } ?>"


Больше этой гадости не где не обнаружил, только на этих разделах.
Помогите исправить ошибку. Бывает даже сама страница форума не грузиться а только загружается пустое окно с кодом этой ошибки.

СообщениеДобавлено: 27 сен 2009, 22:17
xC4x
vit1986
ссылку на форум + тестовый доступ.
$error[] = $user->lang['PM_USERS_REMOVED_NO_PM']
перевести ?
вспоминай ,какие файлы редактировал,проверяй установку

СообщениеДобавлено: 28 сен 2009, 00:34
vit1986
Вспомнил. Был использован мод "notify_admin_on_registration_1_0_0" взятый на вашем сайте. ссылка на мод http://bb3x.ru/mods/info/66
Во время установления мода были выполнены все инструкции...

ссылка на форум http://servis-comp.com/forum/
Тестовый доступ:
login: Вит
Pass: 2003qwertyuiop

Права доступа: пользователь.


Больше не чего не менял и приписывал. Создавал разделы и права доступа в админке.

СообщениеДобавлено: 28 сен 2009, 00:47
xC4x
vit1986
ну дык при установке ты редактировал файлы в соответствии с инструкцией по установке , смотри ее и копай возможно в язык

СообщениеДобавлено: 28 сен 2009, 02:14
vit1986
Все, я разобрался в устранении проблемы, но так и не понял откуда произошла эта ошибка. И это отнюдь не "КРИВЫЕ РУКИ или ТУПАЯ БАШКА НА ПЛЕЧАХ". Точнее, я случайно нашел ответ одного автора в статье, где он рекомендовал проверить скрипт в файле (includes/ucp/ucp_pm_compose.php).
В этом файле и начал поиск скрипта этой ошибки.

Вследствии, как выяснилось уже потом, в конце этого файла был продублирован системный скрипт этого файла. Причем был продублирован конец скрипта без его начала.

В коментарии было написано, что скрипт отвечал за:
//print a notice about users not being added who do not want to receive pms


В моде, который я указал выше этого файла нет в помине. Сам я его не менял и так грубо не испровлял. Так что, как я сказал это не мои кривые руки.
Но почему был продублирован скрипт для меня осталось загадкой....


Большое спасибо администрации сайта, а особенно xC4x за своевременное реагирование на мою проблему. Отчасти его совет и намек мне тоже помогли в поисках ошибки.

Тему можно закрывать.

СообщениеДобавлено: 15 июн 2010, 15:08
anana
В фтп ничего не меняла, но возникла такая проблема. ЛС отправляется, но получатель его открывает а там белая страница, пробовала заменить ucp, но ничего не изменилось. В настройках форума ЛС разрешены. Что делать??

СообщениеДобавлено: 15 июн 2010, 17:00
crash
смотреть логи сервера

СообщениеДобавлено: 15 июн 2010, 19:13
anana
Смотрю, и что? Можно подробнее ответить?

СообщениеДобавлено: 15 июн 2010, 20:15
crash
и смотрите ошибки.

СообщениеДобавлено: 19 окт 2010, 14:57
anana
Ребята напишите плиз в личку кто может помочь с этими личными сообщениями, проблема до сих пор не решена :cry: