Страница 1 из 1

не работают моды в нестандартных стилях

СообщениеДобавлено: 26 янв 2010, 02:40
Вася
Я в этом деле новичёк и вопрос у меня будет совсем глупый, но всё же подскажите, если можно.

Проблема такая. Скачал и установил сборку наиболее полную, в админке разбираюсь с функциями, и как ни странно разобрался. Решил скачать новые темы(стили), скачал, установил, но появилась проблема.
При вновь установленных темах не работает ни репутация пользователей, ни новости в начале, ни благодарности (спасибы). ну и разумеется не работает такая общая вещь как портал. При изменении обратно на стандартные всё отлично работает.

Подозреваю что надо лезть в код у вручную что-то править, а этого очень не хочется, т.к. высока вероятность что накосячу. Подскажите, как сделать чтоб заработали моды на вновь установленных стилях?

СообщениеДобавлено: 26 янв 2010, 14:02
Nekstati
1. Прочесть темы на phpbb.com, в которых обсуждаются соответствующие моды, и посетить сайты авторов этих модов. Есть вероятность, что там найдутся правки для ваших стилей.

2. Править самостоятельно. Большинство нестандартных стилей по коду очень похожи на один из двух стандартных — Prosilver либо Subsilver2.

Re: не работают моды в нестандартных стилях

СообщениеДобавлено: 26 янв 2010, 17:14
Вася
Прочёл, точно такой же проблемы не нашел, были похожие. Сделал из прочитанного вывод что надо править код. А вот теперь вопрос. Код какого именно файла и какие строки надо править, если например я хочу (начну с простого) в теме Milky Way работал мод User Reputation Points.

СообщениеДобавлено: 26 янв 2010, 18:30
Nekstati
Я же вам говорю:
Большинство нестандартных стилей по коду очень похожи на один из двух стандартных — Prosilver либо Subsilver2.

Milky Way сделан на основе Subsilver2. Читаете в инструкции по установке мода всё, что касается Subsilver2, и выполняете то же самое для Milky Way.

СообщениеДобавлено: 26 янв 2010, 18:50
Вася
Спасибо за ОЧЕНЬ исчерпывающий ответ!